我们不是Java的粉丝。坦率地说,考虑到所需的持续更新以及无法关闭Java更新检查,它’是时候换些新东西了。我已经愉快地使用SAPgui 7.2一年以上了。我们的开发人员最近遇到了旧版SAPgui的问题,该问题已在7.3中修复,因此是时候进行更新了。我下载了SAPGui 7.3 rev 8并将其安装在Mac上。这应该像我想象的一样容易。可悲的是’t. 屏幕截图2014年8月16日上午11.24.51 首先,我收到一条消息,它找不到当前的JRE,我不知道’我没有安装JDK,但已经安装了JRE,我认为它运行良好。 屏幕截图2014年8月16日上午11.24.59 由于仍然安装了旧的SAPgui,因此我检查了一下是否仍然可以运行,并且可以使用它来解决正在发生的事情。 屏幕截图2014年8月16日上午11.28.36 从外观上看,即使我一年前成功安装了Java 1.70,SAPgui仍在使用1.60,这是Apple默认提供的Java VM。这就是为什么我讨厌使用Java。因此,现在我有两个不同的版本正在运行,但是像大多数公司一样,我们只希望运行一个版本,以便我们可以尝试并支持它。果然,运行Java时–它列出了1.6版。 屏幕截图2014年8月16日上午11.35.56 根据提示,我在JDK 217MB上下载了完整版本并进行了安装。 屏幕截图2014年8月16日下午12:00 那解决了问题。显然,最新的SAPgui版本需要完整的JDK安装,而不是大多数人已经安装的JRE。 屏幕截图2014年8月16日下午12.02.54 I’我会在稍后探讨原因,但想分享解决方案。

固定在Pinterest上

分享
分享这个